Skip to main content

How to incorporate json file into mcworld file to disable creative mode

Comments

7 comments

  • Debbie Alexander Community moderator
    Beacon of Knowledge Expert (Gold) Moderator

    Hi, Kevin Tan - I think an escape room in Minecraft sounds crazy awesome! I do not know the answers to your technical questions, although I admit I will gladly eavesdrop at the windows for the answers!

    I can tell you that there are two main ways for us non-employee types to share worlds. One is to upload our exported world to a cloud-based storage location, and share the link here or on social media. I have shared worlds that way in the past. Another way is to become a Minecraft Mentor, and submit a Lesson with a world to be published on the site. It it well worth considering applying! =]

    0
  • Dan Noble Community moderator
    Minecraft Certified Beacon of Knowledge Expert (Gold) Moderator

    Hi Kevin Tan

    Sounds like an interesting and exciting project you've created. 

    To use the .json file: 

    1. Export your world to your desktop. 

    2. Change the extension from .mcworld to .zip

    3. Extract the file. 

    4. Copy the education.json file (you can use the same one from Good Troubles. 

    5. Paste the .json file into the root folder. 

    6. Compress the file back into .zip. 

    7. Change the .zip extension to .mcworld and then import it back into the game. 

    Let us know how you make out!

    1
  • Kevin Tan

    Dear Dan,

    Mannnn, I was soooo excited when I finally got the answer to my problem. Unfortunately... I did all the steps as you mentioned. The education.json file is there alright, just that it is ignored and I can continue switching to creative mode as I please. How do I get it to load the education.json file?

    Kevin

    0
  • Aleece Landis
    Expert (Gold)

    Hi Kevin,
    I messed with or tried to mess with the education.json files a year or so ago I think.  Let me see if I can unearth what I learned.

     

    0
  • Aleece Landis
    Expert (Gold)

    Ok, I just tested pasting the educaiton.json from good trouble into a world I've been testing things on. and it appears that now I can't use the /gamemode c.

    So it does work.  I did NOT do the export, rename to zip, edit then zip, rename .mcworld and then import.  I simply stuck the education.json file into the world I was working on (tricky part there is knowing which folder that is since they name the folders all crazy instead of simply putting the level name on the folder.)

    Make sure you are indeed in the copy of the world that you have put the educaiton.json into AND that you have shut down and re-started minecraft.

    0
  • Kevin Tan

    Hello Aleece,

    Your comments got me thinking... maybe I have been looking at things the wrong way. So I went ahead to test it out.

    1. My world's base was a Flat world. Not sure how Lessons in Good Trouble started out as. In both worlds, having education.json in it disables users from typing /gamemode c.... so it works in that sense. However, in both worlds, players can float. In Good Trouble, players cannot break blocks, even if I change settings to Creative, in mine, they can (which is what I don't want)

    2. Does that mean I need to place deny blocks to the whole of my level if I really want to prevent players from hacking the walls and cheating? There must be an easier way (ie. How do I stop players from changing Settings to Creative, ie. ignore it just like Good Trouble)

    0
  • Kevin Tan

    Hello again Aleece,

    I figured out how this can be done now. So apparently there is a command called /immutableworld true

    So after I did that, I add the education.json file so players cannot invoke the command and make immutable world false. Boom... done.

    Just submitted my game level (Escape from Bebras Tower). Let's see if it will be published after the admins go through it.

    Kevin

    1

Please sign in to leave a comment.