Skip to main content

Escape Estate stuck loading code builder on my device



  • Official comment
    Laylah Bulman

    Hi Sarah! This is frustrating I’m am sure. I have been unable to reproduce this error on Mac, Chromebook or PC. I think you’ve submitted a claim ticket, correct? This will help dive deeper into the issue for you.

  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Hey Sarah!

    Hmmm interesting, thanks for all the info.

    Could you let us know the device specs?

    Also is it repeatable after client restart?

  • Bug Zapper Super Star

    I just uninstalled the whole thing, including the Minecraft Education folder in AppData, and reinstalled. Still can't launch the tutorials. I have no idea what's happening. I have used this world and Coding FUNdamentals SO many times without issue, and every usual trick up my sleeve is failing.

    Windows 10 Pro

    System Type    x64-based PC

    System SKU    ASUS_MB_KBLX

    Processor    Intel(R) Core(TM) i9-10920X CPU @ 3.50GHz, 3504 Mhz, 12 Core(s), 24 Logical Processor(s)

    64GB RAM

    60GB free space on the drive



  • Bug Zapper Super Star

    I've tried a couple more of the tutorial worlds. Once when I opened code builder in FUNdamentals 1.2 I got a brief flash in the "Starting tutorial" space of something that looked like "Update download complete. Reloading." or something, but nothing happened and the tutorial is still stuck on "starting."

  • Dani Noble
    Moderator Beacon of Knowledge Super Star

    Hey Sarah Elliott

    Sorry to hear you're having issues. 

    Just some thoughts that occur to me: 

    1. Have you tried the alternate PC install (store vs. .exe, whichever you had installed first).

    2. If you had the .exe install, you'll have better access to all the program files folders. I'd go digging and see if the uninstall left anything behind that you would need to be deleted. 

    3. See if there's any related registry items related to ME left behind. 

    4. If there's copies of the Escape Estate still in your game, delete them all. 

    By the way, nice system! I bet that really flies! 

  • Bug Zapper Super Star

    I had the .exe install. Is there anything other than the folder in Roaming that I should have deleted after uninstalling?  

    How do I check the registry?

    The "View my Worlds" folder was completely blank after the reinstall. No worlds. (I have backups saved elsewhere)

    It was a build specifically for streaming Minecraft during virtual lessons!  And yet it still struggles with RDR2. 😂

  • Dani Noble
    Moderator Beacon of Knowledge Super Star

    Danny Sarah Elliott I've done some further testing on my end. 

    This is definitely an issue with the Escape Estate world, at least on Windows machines, both 10 & 11 (I don't have any other platforms to test on.)

    From what I can see, when you load the game and the codebuilder starts, very briefly (blink and you'll miss it), there's a green "Updating..." message that flashes under the coding agent. Once this happens it gets stuck loading. Message does not appear on subsequent loads of the game, even if I delete the world and reload it. Interestingly, if I try to start the codebuilder at any point prior (such as before you click the poster to start the game), it loads just fine (there's just no coding to do).   

    I'm going to continue to try to see if I can find a work around and will advise if I find anything. 

  • Dani Noble
    Moderator Beacon of Knowledge Super Star

    No work around that I can find on Windows platforms. 

    Was able to borrow an iPad and tried it there... worked perfectly.

    So this is a bug specific to Escape Estate in Windows 10 and 11. 

  • Bug Zapper Super Star

    Dani Noble Can you get Coding FUNdamentals to work, because I'm having it happen there, too. I think it's specifically a tutorial issue.


  • Dani Noble
    Moderator Beacon of Knowledge Super Star

    No issues found with Coding FUNdementals, at least the first one. 

    Just got a friend to check out Escape Estates on a couple of different model Chromebooks; it's working perfectly, so the issue seems to be specific to Windows 10 and 11. 

    That said, it just started working on my Windows 10 computer for no real reason I can discern. I accidentally hit immersive reader while Dr. Breakowski came up and cancelled it, but I think that was just a coincidence. Tried that on my Windows 11 system, codebuilder still doesn't work. 

    Danny, at this point I'm wondering if it's a communications thing. Codebuilder seems to be trying to connect somewhere for Escape Estate, and just can't seem to do it on Windows systems most of the time. I'm wondering if there's a server somewhere that needs a kick. 


  • Bug Zapper Super Star

    A couple more updates, I've tried turning my firewall off entirely, and it's still not loading.  It loads without issue right away on my Macbook.  My Makerspace Technician tried it on her Dell laptop, and it loaded eventually, but took about 15 seconds. (I'm sitting here trying again this morning, and it's been "starting tutorial" for about 15 minutes on the PC. Still no luck).

  • Sarah Elliott
    Bug Zapper Super Star

    Dani Noble I'd been testing in on Coding Fundamentals 1.2, the sea turtles lesson and got the same eternal "starting tutorial."  So I just tried number 1, and I don't even get starting tutorial on that one, just a black screen.I couldn't close the Code builder after that, so I had to force quit the entire application. When I tried loading the world again, I got the "starting tutorial" march and that message flash again!  Too fast to grab it .

    Tested it on Timecraft, and it worked!  But I got the message again!  
    Escape Estate still not working, though.

  • Joshua Guy

    Has anyone had any luck with this issue? Currently facing it with Coding Fundamentals 2

  • Laylah Bulman

    The identified issue relates to caching.

    Justin fixed it!

    The first step below didn't work for me, but the second got it up and running again! Sharing his fix here:

    First, try clearing out your cache for codebuilder. There should be a gear icon or a setting icon that you can select in codebuilder, under that select "Reset". If you can't reach that, try the following:

    Close out of Minecraft
    In File Explorer, navigate to C:\Users\AppData\Local\Temp
    Find a folder called minecraftpe\codeBuilderV1
    Rename this folder (or delete, or zip it up and send to us for troubleshooting)
    Then launch Minecraft again and see if Code Builder comes up

  • Bug Zapper Super Star

    Adding on the potential Chromebook fix as well, for anyone who finds this thread.

    Potential Chromebook fix (this one is untested)

    The folder would still be called "minecraftpe" that holds the codeBuilderV1 folder.  Since the file paths can vary on different Chromebook devices, you can search for this folder in your Files app. Make sure to click on the vertical dots in the top right and select "Show hidden files" and "Show all Play folders" to make sure your search is pulling up the right result. Then, delete the codebuilder folder and launch Minecraft Education again. 

    If that doesn't work, someone was also wondering if the cache may live somewhere in this folder for Chromebook: Settings > Apps > Manage Your Apps > MEE > More Settings and Permissions > Storage & Cache 

  • Andrei Hnidzenka

    I still have the same problem with some of my students. Apparently optimization for some PC systems does not work well. Resetting inside Minecraft does not help, so we delete the folder according to the instructions above.


Please sign in to leave a comment.