Skip to main content

My bow and crossbow aren't visible in the nether (1.17)



  • Dan Noble Community moderator
    Minecraft Certified Beacon of Knowledge Expert (Gold) Moderator

    That is a bit weird! 

    First question, are you on a chromebook or a Windows PC? 

    I'd suggest (if you haven't already done so) restarting your device. Also, weird things happen on Chromebooks if they haven't received OS updates and been shutdown recently. 

    You can check the OS on a chromebook by clicking on the clock in the bottom right hand corner, selecting settings>about chrome OS and clicking "check for updates". Restart when prompted. 

    Hope this helps and let us know how you make out. 

  • Andrew L Support Team
    Expert (Gold)

    Hi there Shadow Wolf. I'm sorry to hear about this issue. In this case I would wait for another update that may bring a fix for this, as it looks like this was a bug that carried over from Bedrock edition into Minecraft: Education Edition. I would try this with a non-enchanted bow for now. 

  • Kira Mangan

    Um what I think is the fact that your in a different dimension. Did you enter the portal recently when this happened because I think this happened to me too.

  • Shadow Wolf

    Dan Noble Thank you but I am on neither of those and I have tried updating and restarting my laptop and it still doesn't work.

  • Shadow Wolf

    Andrew L Thanks, weirdly unenchanted bows/crossbows don't work but enchanted ones do.

  • Naman Rajan

    I tested it in the nether and both crossbow and bow and it works perfectly fine in 1.18

  • Shadow Wolf

    Naman Rajan Thanks!


Please sign in to leave a comment.