Skip to main content

Clone command



  • Dominick Support
    Bug Zapper Support

    Greetings Leticia from Dominick at Minecraft Education support!

    To help further can you let me know what device and OS you're running this on? If your able to re-produce the issue, screenshots or a video would also help me troubleshoot this. Sorry for this issue happening and thank you for your patience. 


  • Leticia Ahumada

    Hi Dominick,

    I tried from my iPad ios 15.2 and my Windows 10 laptop, both running v1.17.31. Here you have a video of the issue:

    Thanks to you for helping out.

  • Debbie Alexander
    Moderator Beacon of Knowledge Super Star

    Hi, Leticia Ahumada - I tried this command, and it worked fine. As a note, it didn't work the first time when I selected an area that did not include the glass blocks. Can you try selecting a larger area that definitely includes the border blocks? (I haven't tested those blocks yet, but it is true that they are a special case)

    /clone ~ ~ ~ ~2 ~3 ~2 ~ ~20 ~ filtered move glass 0


    /clone -20 64 69 -22 64 69 -22 64 70 replace normal
    Worked to make a clone of the border blocks and

    /clone -20 64 69 -22 64 69 -22 64 70 replace move
    Worked to destroy the existing border blocks and place them in the new location (move)

    I couldn't get clone to work with border_block with filter.

  • Leticia Ahumada

    Hi Debbie,
    Thanks for your testing. I know that the command works with other blocks, that's why I specified the problem is only with the border blocks on filtered mode.
    If I use the command clone replace move is going to move all the blocks in the area and what I need is only to move the border blocks, that's why I need the filtered.

  • Debbie Alexander
    Moderator Beacon of Knowledge Super Star

    On a similar note (I know it doesn't help with your problem but it *sort of* relates, so I thought I would tuck it here,) the 

    say(world.is_block("-13 4 -3","COMMAND BLOCK")) 
     in Python Azure Notebooks doesn't work on the command blocks. I have tried every spelling I can think of for the block. It works for the grass blocks, but cannot detect a command block. I think it is a similar problem to the border block, being a specialty block, and not being included in the implementation somehow.

Please sign in to leave a comment.