Skip to main content

Minecraft Education Version 1.17.30 on Mac crashing on startup



  • Dani Noble
    Moderator Beacon of Knowledge Super Star

    Hi Tim Tschirner

    It's possible it may be because your mac is 7 years out of support. In my experience, macs don't play well with a lot of software outside of that window. 

    That said, you can put in a support ticket, and the team might be able to provide you with a better answer than I can. 

  • Tim Tschirner

    Yeah, the iMac is definitely a little bit on the older side :) That said, it still meets all the System Requirements from a hardware and software perspective and previous versions worked fine, so I'm hoping there's a way this can be fixed.


    I submitted a support ticket, fingers crossed!

  • Dominick Support
    Bug Zapper Support

    Hi Tim just letting you know I have looked at your ticket and have it sent to the engineering team. Thanks again for your patience.

  • Adam Strzelecki

    Dominick please note that there was much older issue report on this under but access to this post has been removed "You're not authorized to access this page". So this should been known to engineering team at least since 2 months.

    I had to install Windows (and pay for the Windows license) on my son's 2011 iMac with 12GB Ram running macOS High Sierra (10.13.6).

    Also the problem was not fixed by latest 10.17.31 update and it is still crashing.

    Where can we expect any actions? Feel free to PM if you want me to test some beta build - I am SW Eng.

    Process:               minecraftpe [399]
    Path:                  /Applications/
    Version:               1.17.31 (
    Code Type:             X86-64 (Native)
    Parent Process:        ??? [1]
    Responsible:           minecraftpe [399]
    User ID:               501
    Date/Time:             2021-12-21 13:12:21.819 +0100
    OS Version:            Mac OS X 10.13.6 (17G14042)
    Report Version:        12
    Anonymous UUID:        87B43712-B6C1-EA6A-C03F-3AF564D5CFD6
    Time Awake Since Boot: 36 seconds
    System Integrity Protection: enabled
    Crashed Thread:        0  Dispatch queue:
    Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
    Exception Note:        EXC_CORPSE_NOTIFY
    Termination Signal:    Segmentation fault: 11
    Termination Reason:    Namespace SIGNAL, Code 0xb
    Terminating Process:   exc handler [0]
    VM Regions Near 0:
        __TEXT                 000000010cca3000-0000000113237000 [101.6M] r-x/r-x SM=COW  /Applications/
    Thread 0 Crashed:: Dispatch queue:
    0     0x0000000111405025 AppPlatform_osx::onNetworkChanged() + 37
    1 0x00007fff469d7d03 reachPerformAndUnlock + 589
    2       0x00007fff3a439b01 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
    3       0x00007fff3a4f1e5c __CFRunLoopDoSource0 + 108
    4       0x00007fff3a41cab0 __CFRunLoopDoSources0 + 208
    5       0x00007fff3a41bf2d __CFRunLoopRun + 1293
    6       0x00007fff3a41b787 CFRunLoopRunSpecific + 487
    7           0x00007fff396fbd96 RunCurrentEventLoopInMode + 286
    8           0x00007fff396fbb06 ReceiveNextEventCommon + 613
    9           0x00007fff396fb884 _BlockUntilNextEventMatchingListInModeWithFilter + 64
  • Dominick Support
    Bug Zapper Support

    We have an older build you can try to see if that helps with the issue. 
    We have a trend going about this where High Sierra OS systems are running into this. If your able to update your OS that is the current fix, if not try this older client as a workaround. 

  • Adam Strzelecki

    Dominick The older 1.14 build works fine, but using old build is a solution since there are so many improvements in 1.17 vs 1.14. Also, I'd upgrade macOS if it was possible, but my son's iMac 2011 can run 10.13.6 at most. I don't want to now throw away perfectly capable computer because Apple does now want to support it anymore.

    I really appreciate that you did not drop 10.13 support yet :), so it looks only AppPlatform_osx::onNetworkChanged (getProxy) has to be fixed to make 1.17 working properly.

  • The same thing happens to me, i'm on a MacBook Pro 14" with an M1 Pro running macOS Ventura 13.0.

  • Henry Do

    Im having the same problem on Windows 11. Can you help?

  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Hey Henry, 

    Have you downloaded our latest version 1.18 and are still experiencing crashing on startup?

    Have you tried restarting your device after install as well?

    Let us know!


Please sign in to leave a comment.