Skip to main content

GOAT Beta Technical Issues and Bug Reports



  • Official comment
    Penny Support Team

    The GOAT release is now live!  Check out this article for more information about how to get the full release.

  • Ian Wilkinson

    I couldn't find the e sports and extra maps I'm on the windows store version

  • Penny Support Team

    Ian Wilkinson thanks for this report.  There is a known issue with the library that our engineers are currently working on.  Different users are seeing different versions of the library, which includes different sets of subject folders.  

  • Duncan Reynolds

    Hello and thanks for a great update,

    I have tried uninstalling 1.14 and downloading the GOAT Beta twice but both times it has worked for less than 10 minutes before it closes automatically. I then have to go back and log-in again (enter all details etc.etc.)

    Since I dont have this problem with 1.14 I have disabled the BETA. I have a clubs and camps license.

    Is this a klnown problem? anything I can do? Thanks and regards

    Duncan from Australia

  • Penny Support Team

    Hi Duncan Reynolds - could you provide more info for us so we can investigate?

    • What type of device are you using?
    • What OS are you running?
    • Are you seeing the game shut down at the same place, or is it pretty random?
  • Duncan Reynolds

    Hi Penny

    1. I am using HP Laptop 17-bs0xx (Name

    8CG80205QP )

    2. I am running Windows 10 PRO OS

    3. No the BETA stops working at different places and after different time intervals. It is random



  • Bui Thi Ngoc Bich

    With Beta, I can't play UNESCO Build challenge.

    I've have to uninstall 1.17 Beta. I install 1.14 again, and eveything it's ok.


  • Mohammad Bajwa

    do you mean Support

  • Penny Support Team

    Duncan Reynolds I'm going to open a support ticket so we can collect more information from you.  Watch your inbox for an email from our support desk!

  • Dylan Kelley

    prob because different internet or different country nah 

  • Andrew L Support Team
    Expert (Gold)

    Bui Thi Ngoc Bich I've created a ticket in our system to reach out to you for more information.

  • Zamiel Clayton


    Are you guys going to fix the music and music disc problem? 

  • Eli W.T

    I downloaded the beta and the sign in button isn't working and it just says to check my internet connection. Ive reinstalled and restarted my computer but it just wont work.

  • SEGA B

    Ive been playing beta with my friends for awhile and only problem we have found is you have to break crafting tables twice a lot of times


    I'm trying to join my brother's world, but it won't let me. I thought, "okay, maybe it's just the internet." So I waited awhile, and tried to join my friend's world, when this message popped up saying, "Unable to connect to world" So I figured it was my wife...again. so I waited...and waited...Until I found out that my brother (who has NOT join beta) could join his friends (who also does NOT have beta) world. I figured, "it's a beta thing-".

  • Debbie Alexander Community moderator
    Expert (Gold) Moderator

    Okay, KAYLIN FROST - If you are in the beta group, you would definitely have to join in a world with other folks who are in the beta. friend, wife, whoever, but they would have to be using the MinecraftEDU version with an office365 account. Folks who are not in the beta group are a different story, and that would go in another thread. Let us know if you need more help. 

  • Penny Support Team

    Eli W.T check out this article about troubleshooting the error message about needing to check your internet connection:  Troubleshoot the Can’t Connect to the Service Error – Minecraft: Education Edition Support

  • Lincoln Drosse

    So I have been playing on the Beta, and ever since the Nether Update was released on Java in 2020, I have never been able to experience that amazing new world, and it is really cool with the Caves & Cliffs Update part 1, I love experimenting with blocks and using new mechanics I've never seen before. All of that is cool, but there are a few problems. I am aware this is a beta, and these problems may be already getting fixed by the awesome game coders/developers, but my game has shut down multiple times on random occasions when playing the game. And when I have been playing on one of my Minecraft Playthroughs, every time I enter my nether portal, to go to the overworld, the game lags and there is a lot of latency. I wait about 30 seconds after leaving my nether portal, which is really annoying because I have died multiple times, not able to run from hostile mobs. I don't know why it has reason to lag so much, all i have is a few sheep, chickens and cows, which shouldn't really make it that laggy. So I presume the Beta itself isn't stable enough yet (btw I've played on the world for only a week and its this bad. There are Minecraft Youtubers who have large redstone projects in their Hardcore worlds and they don't even lag a bit!) to play on, but I hope the app has more power in future to run larger worlds without a problem.

    Thanks in advance.

  • Phu Mai

    After playing the beta for a bit, I noticed that items weren't properly organised or consistent in the Creative Menu. Notably the new amplified slowness potion. It falls at the very end of the potions list, whilst the rest of the slowness potions are together in the middle. I know this might be intentional as re-arranging the amped slowness potion can mess with the item IDs, but it would be a piece of mind fix.

    It also displays slowness IV for 15 seconds, like turtle master. I'm not sure if this is how it is meant to be, as I have yet to play in 1.16 nor 1.17.

    Other Menu organisation stuff is:

    - Prismarine Brick in the 'Decorative Stone' tab (this one is sort of a grey area, but I personally prefer all the prismarine blocks together)

    - Cracked and Chiseled nether brick block appear after bricks and not nether bricks

    - Deepslate Emerald Ore appears before Deepslate Coal and Copper Ore, whereas normal Emerald Ore appears last

    Another small thing I noticed is with structure blocks. When a structure block is set to 'Load', and ctrl + middle-clicked to obtain item Data, and is then placed it doesn't load the structure. Despite having all of the correct setting and configuration in the block.

    Side Note:
    I will be playing the betas a lot more, and will be looking out for more issues/bugs. This is especially apparent as me and my friends like to modify and push the game to its limits (in a good way). I hope that I will be able to send more bugs/issues and I hope you and/or the dev team can fix them.
    I have also made a post of this on technical difficulties but decided to make a copy here as it is more relevant.

  • Phu Mai

    My friend and I were testing out the beta together and we noticed a few more things.

    - He occasionally experienced “ghost trapdoors”. This is where he would shift place the trapdoor and be able to walk straight through it. He could even interact with it. After a while, save and quitting the world or relogging, or replacing the trapdoor, the problem was fixed.

    - A major building issue was the ability to simultaneously press left and right click in creative to replace blocks. Instead, the left click would take priority and ignore the right click. Resulting in just the block being destroyed.

    Aside from these, the team is doing incredibly and I am very please with the progress made. There are just a few minor Bedrock Edition bugs.

    - the inventory can lag, stopping you from selecting anything or doing anything. The GUI jut needs to be closed and reopened, but it really bothers many players.

    - when opening chat with /, there can be some lag. This was not apparent for me in 1.14.70.

    Just to clarify, I use an Intel CORE i7 CPU and run an average of 60fps. So any lag or glitch I experience is usually not to to with my system.

  • Phu Mai

    Upon further discussion, the “ghost trapdoors” mentioned above have now seemed to stop. I’ve theorised that it might have happened due to the beta just being installed and few minutes prior and the game just needed a bit of time.

  • Phu Mai

    Yea that sometimes happens. I think it’s just because the game is having issues reconnecting to to the local server again.
    Is it happening every time you close your device?
    Eg. you shut the lid of your laptop

  • Phu Mai

    Bug Report:

    I don’t think this is supposed to be a thing but;
    When holding doors in the main hand, the texture displayed is a very simple and pixelated version.

  • Phu Mai

    Bug Report:

    Major issue that is in the game:

    I know that this may already be addressed, but there are known 1.17 Bedrock Edition bugs still prevalent. These include:

    - The player hand not showing when holding items like bows
    - Enchanted bows are invisible in the First Person main hand
    - The render offset for bows isn't present; it is being held like a tool such as a sword or pickaxe
    - Some animations or animation controllers aren't present

    I know that this is a common issue in the Bedrock Edition Community and is being addressed in some newer version like 1.17.34 (this is the latest form the top of my head) or even changed/fixed in the coming 1.18 release. 
    Just thought that it would be good to let the team know that these things are still present, even in Education Edition.

    Side note: Yes, I do have quite a deep understanding in Bedrock Edition coding, so I will and/or try to refer to issues in technical terms.

  • Oscar Sharpe

    Spawn glitches.

    There are a lot of a beta spawn glitches as sometimes 10 skeletons will spawn on one block and explode everywhere. The same thing happens with zombies and creepers and passive mobs. It gets really laggy and makes it impossible to survive the night without sleeping.

  • Cameron Ross

    I have a world that was created pre-Beta. I have since installed GOAT Beta on my teacher laptop and all students laptops are am experiencing the following issues:

    • students who played in this world pre-Beta now cannot join. They can enter the join code, see my name and "confirm", it says joining game but at the end of the normal join process the entire game crashes with no error message displayed
    • students who did not play in this world pre-Beta can join, but once they exit they cannot rejoin the same world, the game crashes as above. They can join duplicate of the world easily, but they cannot rejoin the same instance of a world so cannot continue working on projects
    • I have tested students on a new world that I created in the after installing the Beta release and do not experience the same issues, it is only with this particular world file that was created pre-BETA (I have a backup from pre-Beta)

    This world is one that I have been working on for over a year so i'd really like to work out what is going on and is the main world I use with my coding classes. Pre-Beta I had many classes using this world, and they would rejoin many times without any issues.

    I'm hoping it works once the full release comes out but I thought I should make you aware of this strange issue.

  • Ahamd Hasabala

    my mountains aren't loading in


  • Cameron Ross

    Not sure if you've noticed it already, but the subtitles are not working properly in GOAT Beta.

    If a subtitle is longer than the width of the screen, it used to wrap around and go onto 2 lines. Since the Beta release long subtitles now extend beyond the width of the screen and remain on a single line. Can this please be fixed so the subtitles wrap around again?

    Thank you for all the hard work getting the GOAT Beta released, my students really enjoy the extra features, especially the ability to take photos and post them on a wall.

  • Penny Support Team

    Hi Cameron Ross thanks for your reports.  There were some incompatibilities with old content in the 1.17 build that the team has fixed over the beta period.  I'm going to open a ticket and ask that you send the world so we can see if these issues still repro in our newer builds.  

    For the subtitles, could you post a couple of screenshots so we can see where you are seeing the wrap issues?



  • Rafael Cardoso

    When I try to sign in it says " We can't connect to the service you need right now. Please check your internet connection and try again" what do I do? I also only have the desktop version.


Post is closed for comments.