Skip to main content

iPad Unable to access library *COMMUNITY HELP NEEDED*

Under consideration

Comments

12 comments

  • Bundabrg

    I posted a ticket but just want to add that I tried the user on 2 separate ipads (the second running ios 14.2) with the same error, and I then tried a user from a different tenancy with the same error on the same devices. Let me know if you want a full packet dump.

    0
  • Heather Drolet

    Hi there,

    I have students who get this message on Chromebooks (I haven't tried with iPads yet). The strange thing is that some kids get the message, and some don't. I can't figure out why only some kids can access the library. Can someone point me in the direction of information that can help me and my IT admin?

    Thank you!

    1
  • Bundabrg

    A possible workaround may be to export the worlds on something that does have access and then load the worlds on the devices that do not have access.

    0
  • T S

    still having this issue is there any fix for it?

    0
  • Debbie Alexander Community moderator
    Expert (Gold) Moderator

    Kyle M We get problems on the iPads loading, but never with this exact message. I have been watching ;]

    Is it only this exact message you want? We are in the right conditions otherwise. Usually we just restart the iPad and hope for the best. Our observation is that the Minecraft app doesn't do well with changing from access point to access point on the network, so the restart allows it to reconnect directly. idk if this is an iPad issue or a Minecraft issue, but this is our classroom experience. We do keep records, but not of every restart. Let me know. We only have a couple more weeks. =]

    -1
  • unidentifiable 14524

    I have the same problem but on Mac please help!

     

    1
  • unidentifiable 14524

    help!!!!!!!!

    0
  • Nathan Wolf

    Hello, I am sorry to bring up an old post, but this is the most recent one I can find about this issue. I have found a few others, but they all lead to the "whitelist these domains" answer which I don't think is the case here.

    I am having this issue but on Mac OS, and only for one specific OS user account on that laptop.

    If I log in as a separate Apple user on that same laptop, then log in to Minecraft edu (same Microsoft account), Library access works fine. There is no firewall enabled on the laptop (for any users) nor any outbound firewall on our network. I have also tried connecting the computer to a hotspot. I don't think it is network related, it seems to be some problem with this specific user account, so I suspect some corrupted Minecraft user data somewhere.

    I have tried removing and re-installing the app. I have tried deleting the user's ~/Library/Application Support/minecraftpe folder.  This deleted their worlds, but did not fix the problem. It also didn't log them out (nor did deleting and reinstalling the app), so I suspect there is some (perhaps corrupted) user data elsewhere.

    Is there anything else I could try deleting? My last resort is to delete and re-create this student's OS account completely, but I would really rather not do that.

    Thank you for any help or guidance you can give!

    0
  • Bundabrg

    I personally was never able to solve it. A full backup and factory reset fixed the issue but doing a restore would bring back the problem.

    My guess is that it is something to do with caching, certificate pinning or a parental policy (IOS uses a security policy for this) but I ended up just resetting the whole tablet and importing them which was massive overkill to fix 1 app. You'll need to export and reimport worlds but in my case we have a permanent hosted server so I could skip that step thankfully.

    Affected about 50% of the students in the class.

     

    0
  • Nathan Wolf

    Thank you for your response- that is very puzzling. I would wager it's the same kind of thing for me, though I feel like on MacOS it should be a more solvable problem since in theory I have complete access to whatever files are causing the issue. If only I knew which files they were!

    In the meantime I've created a separate user account for her to use when we have Minecraft class, then she'll use her real account for everything else. Not ideal, but better than having to delete her user account, I think.

    It would be great if there was a solution.

    I should also mention that this does not only prevent access to the Library, it also prevents her using join codes (to host or join). She can join a host via a direct IP/port connection, but this is clearly not ideal.

    So far I have just been testing this out with two students, we will be trying a full class next week, I worry if I run into this with multiple other students we are going to have a real mess on our hands.

    0
  • Bundabrg

    You're not Nathan Wolf of "Magic" are you by chance? We've talked before if so ;)

     

    I missed you mentioning MacOS so I think your issue is different to mine. Mine was an oddity of IOS that affected a bunch of students including my own dev devices but even a rooted tablet did not make it easy to debug in the end and I suspect the issue was more to do with some caching or protection triggered in the OS than anything to do with the app.

    As you are unable to access the library AND more importantly are not able to register to get a join code it sounds to me like the machine is unable to access the mcee registration server or in some way is being blocked specifically to that. I'm assuming by creating a new account you're creating a new local account on her pc and still connecting using the same student AD account so this tends to rule out a machine wide issue.

    Anyway good luck. If you're really curious to see if where it might be blocked specifically you can dump the connection through mitmproxy and see what the response to the registration server is.

     

    0
  • Kim James

    I am getting this message on our district Chromebooks, but not on same accounts on PCs. 

    0

Please sign in to leave a comment.