Skip to main content

Unable to connect to the library. Regardless of network settings or device.

Comments

12 comments

  • Official comment
    Kyle M Community team
    Expert (Gold)

    Hello Everyone,

    This error is due to not having the following URLs allowed on your network:

    • https://*.xboxlive.com (Library/Demo Lesson)
    • https://*.playfabapi.com (Library/Demo Lesson)
    • https://education.minecraft.net (Library)

    It should also be noted that all worlds from our in-game library can also be found on our webpage.

  • Philip Golden

    Hi, 

    One of the children today at our coding club had exactly the same "Unable to connect to the library" error as is described in this post. I would be very grateful for any suggested resolution; this prevented the student from engaging with the coding club project for this week. 

    Phil 

    0
  • sofiar102

    Hi Kyle, 

    thank you for the prompt response, however, as I wrote in my message, there is no firewalls on the network, I also disabled Mac OS firewall. And even tried direct LTE connection from iPad or as an iPhone hotspot. I doubt that the whole T-Mobile is blocking your urls. Also I tried to turn off all parental/age content restrictions on iPad and use LTE - no luck.

    Is there exact URLs instead of *, so we can ping them and trace? And we have an Xbox at home and it works perfectly fine, so I don't the problem is in "xboxlive.com" subdomains.

    I tried to search lessons on the web site, but can't find anything, for example I type "hour of code" here: https://education.minecraft.net/class-resources/worlds and it shows empty results.

    Thank you!

    -1
  • Barbara de Vries

    I have the exact same issue. Everything worked fine initially, now constant error with regards to the library. I am so fed-up😱

    -1
  • Barbara de Vries

    I have a class of 15 kids to enroll in this program, but I am not about to buy licenses if nothing works.

    -1
  • Aiza Garcia

    I encountered the same issue in Minecraft Hour of Code 2020. What I did is asked my students to download the map and manually saved it in their Minecraft Education folder on their iPad.

    -1
  • Angel Baker

    idk

    -1
  • Sarah Morgan

    i am having the same thing happen to me. my friends are on it and i can not join them. nothing you said would work worked an all i want to do is play will my friends but cant

    -1
  • Braelynn Halliday

    Kyle M's post was the solution for me but without additional context, the post is quite useless...

    You can "allow" the three URLs Kyle listed by doing the following:

    1) Paste the following into your Edge browser: edge://settings/content/automaticDownloads

    2) Then add each URL preceded by [*.] such as: [*.]xboxlive.com

    3) Once all three URLs are added to the automatic downloads list, restart Minecraft EDU

     

    -1
  • Barbara Allyn

    I was having this same issue on two of the Macs in our house but not the third.  I finally realized it had to do with being an administrator vs not being an admin since that was the only difference between the two not working and the one working.  However, of the Macs that wasn't working was logged in as an admin, but when I created a new user and made the new user an admin it fixed the problem.  Then I made the old user (which was an admin BUT Minecraft Education still getting the "unable to locate library" error message) no longer an admin, restarted the computer, made that user an admin again, restarted the computer... then the original user can now access the Minecraft library and Minecraft Education works just fine.  Messing with the users and "resetting" them to be admins seems to have cleared the issue up on all of them.

    0
  • John Humphreys

    I found another way to resolve it on Windows and it could apply to macOS as well if it occurs.

    Minecraft creates a temp cache folder in the users account.

    If you go to file explorer and type %APPDATA% you will get taken to the users Roaming App Data Folder.

    Note the above folder applies to Windows non store

    Can find the other locations for other OS here:
    Location of World Files – Minecraft: Education Edition Support

    You will then see a Minecraft Education Edition folder.

    WARNING don't delete just rename! as you want to keep your existing worlds! In my case I had none.

    Rename the Minecraft Education Edition folder e.g. "Old MCEdu"

    Then re-run Minecraft EDU it will then recreate the Minecraft Education Edition folder and recache the files. 

    Note if you have existing worlds you will need to copy them across from the old folder. Location of World Files – Minecraft: Education Edition Support

    -1
  • Bryan Sanders Community moderator
    Bug Spotter Minecraft Certified Beacon of Knowledge Moderator Expert (Gold)

    I would rather make a shortcut to a folder buried deep inside of other folders rather than rename the folder structure as set by the game.

    0

Please sign in to leave a comment.