Skip to main content

Trying to move around on a Mac, sometimes makes the keys lock.



  • Hi,

    I reported this issue about 6 months back, also on a Mac.  This was what they were able to tell me about it:

    "You are exactly right. I reached out to the dev team and it is a bug that is logged to investigate further, however there is no current fix or work around that we are aware of for the issue at this time. Sorry about that!"

    So, I guess they're aware of it, just no fix still if it's still not working (haven't tried on a Mac recently).

    The only 'fix' I found for it was pushing the same key again then releasing it if that helps.


  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Hey there,

    Thanks both of you for the reports.

    It could be worth checking if you are still experiencing this issue on our latest beta version found here:


  • Hi Danny,

    Just tried it on the Beta version, still has the sticking issue, still requires pushing the key a second time for it to register the "key up" command/change for which ever key got stuck.

    Hope that helps fix it :)

  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Hey Jeffrey,

    Thanks for checking the beta, sorry it did not help with the issue.

    Though, funny enough, I had a very similar issue with my personal Windows PC the other day which was extremely annoying. Any game I would play, I needed to double tap the key. Then it worked fine for one tap as it should, until I didn't push that key for 10+sec. Very odd and annoying. 

    I uninstalled the drivers for my keyboard completely, and restarted the device forcing it to reinstall the drivers for my keyboard again by itself and that did the trick. I am unsure as to where the drivers on the Mac are installed, but that could a path you could take. 


Please sign in to leave a comment.