Skip to main content

After the update, the command to enable the tutorial stopped working



  • Moderator Beacon of Knowledge Super Star

    Hello, again Łukasz Zaraska - Thanks for reporting the trouble. 

    When I think of tutorials, I think of the in-game tutorials I can access by using "c" and clicking on the pictures in the MakeCode interface or Notebooks interface to learn Chicken Rain or Billboards. It sounds like you are going after something else here. Is this a tutorial which runs in-game for a particular world? Did you make it? Where are you running the execute command? I'd like to help!  

  • Moderator Beacon of Knowledge Super Star

    Danny I think Lukasz has a bug report here. I tried every permutation I could in the execute command. It lists "code" as an option but it won't recognize the token. I tried about 20 different ideas... Let us know how it looks from your end. I could use the /execute run effect just fine, but code or code builder was a no go.

    /execute at @p ~ ~ ~ codebuilder navigate @s false ""

    /execute run code

    /execute as @p run code

  • These are my tutorials for the built educational map. To make it easier for children instead of one long tutorial
    I use many small ones that switch after talking to npc or enabled in the command block.

  • Laylah Bulman

    Debbie Alexander I cannot reproduce this bug. It's working fine for me and team.  Łukasz Zaraska Did you install the newest update? You can test probably be easiest for them to test using something like this:


  • Laylah Bulman The link is not working. I have 1.19.52 version. Have you tested on the new map? because of the maps for the old version it also worked for me. But as similar on the new version to the non-working one

  • Debbie Alexander
    Moderator Beacon of Knowledge Super Star

    So code builder opens for you from the chat window? Laylah Bulman I am updated, my machine is new and pretty clean of possible conflicting apps. This is my error: (WIndows 11 Home) I am also in new version worlds. (and no access to pxt-minecraft on GitHub for me either)

  • Debbie Alexander I found a solution. It was obvious ... In the new version the command looks like this.      /execute as @p run codebuilder navigate @s false lockedEditor=1#tutorial:                                                            But the "Codebuilder navigate" prompt in the console is actually missing.                                                   

  • Brandon Murry


    I'm having the same trouble as you. I've NEVER seen a "codebuilder navigate" option. You seemed to have come up with a great way to dynamically load in new tutorial.

    The only way I've been able to successfully get my tutorials in to a game is to:

    • Export the world I want to use
    • Change the .mcworld file extension to .zip, and extract all the files
    • Edit the "education.json" file so that it includes a "codebuilder" object
    • Change the "defaulturi" key to makecode with the correct #tutorial:"
    • Zip all the files together again, and change the file extension back from .zip to .mcworld

    The problem here is that with this method you are limited to ONE custom tutorial per world. So we just ended up importing a bunch of different .mcworld files, each one pointing to a different tutorial.

    Here is a sample education.json file that worked for us:

            "disableLegacyTitleBar": true,
            "capabilities": {
                        "canModifyBlocks": true


Please sign in to leave a comment.