Skip to main content

Turtle egg error



  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Hey Olivia! 

    Odd, I was not able to replicate the error on my end. The eggs look as they should. 

    Could you share your device's specs, specifically the graphics card?

    Also, what version of Minecraft: Education are you on?


  • Olivia Norris

    All I know is that I’m on version 1.18.42. I don’t know how to find the specs.


  • Dominick Support
    Bug Zapper Support

    No worries, Olivia, so you have anything extra installed for Minecraft Education? I tried as well and couldn't duplicate this. 

  • Olivia Norris

    Nope, not that I know of

  • Debbie Alexander
    Moderator Beacon of Knowledge Super Star

    Hi, Olivia. A number of different things can be happening, so here are some possibilities:

    • Your world file was being saved and the file for the eggs took a turn for the worst in the process. If you were to delete that world, start over (no one wants to do that, of course) and begin the coding again, the problem would disappear, and probably never return. These things sometimes happen when signing out before Minecraft has fully exited, and sometimes I blame sunspots, because, why not? =D But the good news is, there is no underlying problem. I've got my money on this one. 
    • You restarted, so that one was checked (good thinking!)
    • You have a "mod" installed and it is messing with the turtle eggs. This is messier. This requires removing and reinstalling Minecraft, sometimes, to fix it, but it sounds like this is not the case.
    • You can always open another world and set down turtle eggs, and see if MC:EDU hates turtle eggs on your machine now =] but I'd try opening another copy of the game and see if that looks better. Good luck!
  • Aleece Landis
    Bug Zapper Beacon of Knowledge Super Star

    I second Debbie Alexander on doing a few more trouble shooting steps.

    When Danny and Dominik were asking about device specs, what type of device is it a windows pc or a Mac or a chromebook or an android tablet or an Ipad?  With that info they may be able to help you find the "specs" to help with troubleshooting.

    So what I would probably do FIRST.  (provided you have NOT installed any addons, packs, resource packs or mods)

    Start a new world and put some turtle eggs down and see if they look right.  (If they are good then perhaps that original world just got corrupted somehow.  If eggs are still messed up then it might be time to uninstall and re-install your minecraft education edition.  There is a new update now anyway.)

    If you have used any addons, packs, resource packs or mods.  Try creating a new world and NOT enabling the packs.  See what happens.  It is quite possible that a poorly written (or not written for education edition) addon could mess with how things are rendering.

    If neither of those methods clears up the problem, then you will probably want to share more details about your device specs to troubleshoot the problem further.  Are you seeing any other strange rendering on any other blocks or items?

  • Olivia Norris

    I’d like to ask, what do you mean by “open another copy of the game”? I’m on an iPad. Also, I’ve tried out all your troubleshooting tips, and none of them worked.



Please sign in to leave a comment.